We are continuing to monitor for any further issues.
Posted May 19, 2026 - 16:41 BST
Monitoring
We have implemented a fix for the issue affecting Compliance Lens in US Production.
Service is returning to normal, and we are monitoring the environment closely to ensure stability. We will provide a final update once monitoring is complete
Posted May 19, 2026 - 16:40 BST
Investigating
We are currently investigating an issue affecting US Production Environment. From 15:00 UTC May 19, 2026 we are experiencing a Compliance Lens service outage and customers will see error messages for Compliance Lens applications.
Our teams are working to understand the cause and restore normal service. We will continue to provide updates as we learn more.
We apologise for the disruption and appreciate your patience.
Posted May 19, 2026 - 16:27 BST
This incident affected: US: us.trunarrative.cloud (API, Portal) and Third-party Application Endpoints (Compliance Lens US).